Castbrick
Subscribe to updates
Powered by
AFRICELL NETWORK DOWN
Resolved
·
Partial outage
SOLVED
Fri, Aug 21, 2026, 05:53 PM
(
1
month ago)
·
View all updates
Affected components
Aug 21, 2026, 01:01 PM
Aug 24, 2026, 01:53 PM
Africell Network
Updates
Resolved
SOLVED
Fri, Aug 21, 2026, 05:53 PM
Investigating
SMS MAY NOT BE DELIVER
Fri, Aug 21, 2026, 01:01 PM
(
4
hours earlier)
AFRICELL NETWORK DOWN - Castbrick Status